As you know, I take the process of REBOL naming quite serously. Ironically, coming up with the best name for a function or other structure can take more time than writing the entire function in REBOL.
The typemap! datatype is a good example, and we should discuss it right now.
Originally, I thought a better name was typeset! to be more consistent with the bitset! datatype. But, I was concerned about the fact that the word typeset has already has a firm technical meaning in English (even more to those of us who have published books before, which is my own bias).
However, that name conflict really quite irrelevant, isn't it? After all, how likely is it that typesetting will ever have anything to do with REBOL?
So, let's hear your comments on this. I'm strongly leaning toward changing the name to typeset! and now is the time to do it.